zyrusthc-linux.no-ip.org

A Linux Fan Page .... Shellscripts , Mohaa - Cod2 - Battlefield2 - CS - CSS - ET Webinterface ......

Logo zyrusthc-linux.no-ip.org
Donnerstag, 24. September 2020
  • Benutzer

  • Besucher
    Heute:
    90
    Gestern:
    159
    Gesamt:
    338.133
  • Benutzer & Gäste
    3668 Benutzer registriert, davon online: 34 Gäste
 
Start Einloggen Einloggen Die Mitglieder Das Foren-Team Suchfunktion
1932 Beiträge & 333 Themen in 13 Foren
Keine neuen Beiträge, seit Ihrem letzten Besuch am 24.09.2020 - 14:12.
  Login speichern
Forenübersicht » Projekt Webinterface » Keine Reaktion bei Stop, Restart, Update

vorheriges Thema   nächstes Thema  
18 Beiträge in diesem Thema (offen) Seiten (2): (1) 2 weiter >
Autor
Beitrag
veLenoSo ist offline veLenoSo  
Keine Reaktion bei Stop, Restart, Update
10 Beiträge - Grünschnabel
hallo,

hab nun schon alles mögliche ausprobiert und auch das forum durchkämmt, aber mittlerweile weiß ich nicht mehr weiter..

wenn ich das startscript, was bei mir "hlds" heißt über ssh mit ./hlds start ausführe, funktioniert alles einwandfrei.. der server startet, stopt und so weiter..
das startscript liegt in /home/swtest
mein gameserver in /home/swtest/swtest
es geht um einen cs 1.6 server, betriebsystem debian..

auszug aus der config.inc.php
// Counter-Strike 1.6
// User unter dem der Server laufen soll , Eintrag in der /etc/sudoers muss daf�r vorhanden sein.
$csuser = "swtest";
// Das restart, stop und update Kommando
$csrestart ="/home/swtest/hlds restart";
$csstop ="/home/swtest/hlds stop";
$csupdate ="/home/swtest/hlds update";
// Die Konfigurationsdateien
$cs_cfg = "/home/swtest/swtest//cstrike/server.cfg";//Die Serverkonfiguration bearbeiten
$cs_cfg2 = "/home/swtest/swtest/cstrike/motd.txt"; //Message of the Day bearbeiten
// Die ServerLog Dateien
$cs_log = "/home/swtest/swtest//cstrike/logs/";
// IP Adresse und Port des Servers
$csserver = "versteckt";
$csserverport = "27017";
$csrconpass = "versteckt";

hab auch schon probiert bei csuser "www-data" zu setzen, geht aber auch nicht.. www-data ist der benutzer, der mir angezeigt wird beim apache, wenn ich ps aux ausführe..

auszug aus /etc/sudoers
# User privilege specification
root ALL=(ALL) ALL




www-data ALL=(swtest)NOPASSWD: /home/swtest/hlds


in der konfiguration funktioniert es nicht.. kann mir bitte wer helfen, weiß nicht mehr weiter..
danke!

Beitrag vom 19.01.2007 - 14:36
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Hallo

Was wird den in den Logs des Webservers vermerkt wenn du du restart anklickst?

Greeez Oli



Greeez Oli
Beitrag vom 20.01.2007 - 18:03
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
mit $csuser="swtest" kommt im errorlog
sudo: no passwd entry for swtest!

mit $csuser="www-data" kommt im errorlog
Sorry, user www-data is not allowed to execute '/home/swtest/hlds restart' as www-data on server.


Dieser Beitrag wurde 1 mal editiert, zuletzt von veLenoSo am 20.01.2007 - 18:59.
Beitrag vom 20.01.2007 - 18:58
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Ok , www-data darf es nicht wegen den Rechten ist auch in Ordnung so....

Ist den für den Benutzer swtest auch ein passwort mit passwd angelegt worden ?



Greeez Oli
Beitrag vom 20.01.2007 - 19:08
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
ah, das hatte ich vergessen!

aber damit hab ich ein kleines problem.. und zwar muss man ja in der datei .htaccess AuthGroupFile /dev/null angeben.. den pfad gibt es aber gar nicht auf meinem server, deswegen vermut ich geht auch der passwortschutz nicht.. gibt nur den ordner /dev
Beitrag vom 20.01.2007 - 20:04
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
/dev/null sollte in jeden Fall existieren!
Was sagt den ein :
ls -l /dev/null
?

Was /dev/null ist liest du am besten hier nach , besser kann ich es auch nicht erklären.
http://de.wikipedia.org/wiki//dev/null



Greeez Oli
Beitrag vom 20.01.2007 - 20:45
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
dann sagt er mir das
crw-rw-rw- 1 root root 1, 3 2006-12-16 17:13 /dev/null

aber wenn ich z.b. über winscp gucke gibts den ordner nicht
danke schon mal bislang für die hilfe glücklich


Dieser Beitrag wurde 1 mal editiert, zuletzt von veLenoSo am 20.01.2007 - 21:40.
Beitrag vom 20.01.2007 - 21:40
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
/dev/null exisitert also ....

Wo liegt jetzt das Problem?
Funktioniert das Webinterface nun?



Greeez Oli
Beitrag vom 20.01.2007 - 21:43
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
meine .htaccess sieht so aus

AuthUserFile /var/www/swtest/.htpasswd
AuthGroupFile /dev/null
AuthName "Gameserver Webinterface"
AuthType Basic
<Limit GET>
require valid-user
</Limit>

diese datei liegt zusammen mit der .htpasswd in dem ordner swtest, wo auch das webinterface installiert wurde.. allerdings werd ich nach keinem pw gefragt und im errorlog ist die fehlermeldung unverändert
Beitrag vom 20.01.2007 - 21:44
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Hoffe du hast in die .htpasswd keine Passwörter im Klartext geschrieben!
Lesen: http://home.germany.net/101-145626/htaccess/

Funktioniert den auf anderen Seiten auf dem Server der Verzeichnisschutz mittels htaccess ?



Greeez Oli
Beitrag vom 20.01.2007 - 21:49
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
das hab ich schon alles gelesen..
passwort wurde natürlich nicht einfach übernommen, gecryptet..

außer dem webinterface nutze ich den webserver nicht, hab also auch nirgendwo sonst htaccess
Beitrag vom 20.01.2007 - 21:55
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Arbeite mal diesen Thread durch.
http://www.linuxforen.de/forums/showthread.php?t=207316&



Greeez Oli
Beitrag vom 20.01.2007 - 22:08
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
mhh..

/etc/apache2

apache2.conf
die betreffende stelle in der conf sieht jetzt so aus bei mir:

<IfModule alias_module>

Alias /icons/ "/usr/share/apache2/icons/"

<Directory />
Options None
AllowOverride All
Order deny,allow
Deny from all
</Directory>

<Directory "/usr/share/apache2/icons">
Options Indexes MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</IfModule>

httpd.conf
diese datei ist komplett leer.. da steht NICHTS drin..

funktionieren tuts auch immer noch nicht


Beitrag vom 21.01.2007 - 18:58
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Also existiert bei dir nicht dieser Eintrag?

AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>


Wenn nicht, füge diesen mal hinzu restarte den Webserver.



Greeez Oli
Beitrag vom 21.01.2007 - 19:03
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
veLenoSo ist offline veLenoSo  
10 Beiträge - Grünschnabel
keine veränderung
Beitrag vom 21.01.2007 - 19:21
Diesen Beitrag melden   nach weiteren Posts von veLenoSo suchen veLenoSo`s Profil ansehen veLenoSo eine private Nachricht senden veLenoSo zu Ihren Freunden hinzufügen zum Anfang der Seite
Baumstruktur - Signaturen verstecken
Seiten (2): (1) 2 weiter > vorheriges Thema   nächstes Thema

Gehe zu:  
Es ist / sind gerade 0 registrierte(r) Benutzer und 34 Gäste online. Neuester Benutzer: Scarez
Mit 3855 Besuchern waren am 02.09.2011 - 14:07 die meisten Besucher gleichzeitig online.
Alles gute zum Geburtstag    Wir gratulieren ganz herzlich zum Geburtstag:
Freedom (40)
Aktive Themen der letzten 24 Stunden | Foren-Topuser
 
Seite in 0.25923 Sekunden generiert


Diese Website wurde mit PHPKIT WCMS erstellt
PHPKIT ist eine eingetragene Marke der mxbyte GbR © 2002-2009