zyrusthc-linux.no-ip.org

A Linux Fan Page .... Shellscripts , Mohaa - Cod2 - Battlefield2 - CS - CSS - ET Webinterface ......

Logo zyrusthc-linux.no-ip.org
Sonntag, 20. September 2020
  • Benutzer

  • Besucher
    Heute:
    41
    Gestern:
    89
    Gesamt:
    337.462
  • Benutzer & Gäste
    3668 Benutzer registriert, davon online: 33 Gäste
 
Start Einloggen Einloggen Die Mitglieder Das Foren-Team Suchfunktion
1932 Beiträge & 333 Themen in 13 Foren
Keine neuen Beiträge, seit Ihrem letzten Besuch am 20.09.2020 - 23:28.
  Login speichern
Forenübersicht » Projekt Webinterface » Problem mit cod servern

vorheriges Thema   nächstes Thema  
10 Beiträge in diesem Thema (offen) Seiten (1): (1)
Autor
Beitrag
Gast thanatos74  
Problem mit cod servern
Gast
moin moin,
ich habe ein Problem mit den call of Duty servern, sowohl cod als auch cod4

1. ich hatte es schon mal alles am laufen, nur dann hatte ich nen Problem mit dem root, der musste neu installiert werden.
Da hatte ich 2 cod4, 2x cod5 3x bf2 1x css 1x cs 1.6 am laufen..

2. habe webinterface 1.3 wieder draufgehauen,
Battlefield 2 server klappt ohne Probleme..

Nur jetzt gehen die cod server nicht mehr....

Das Problem ist, wenn ich auf "Server restart drücke" schreib er...
"Kommando Start wird ausgefuehrt
Starte call of duty: cod1_port28961
... Server gestartet.."

aber es passiert nichts.

Wenn ich den server manuell starte, und mal in das Webinterface schaue,
ist er auch zu sehen, ich kann sogar die "werte" ändern usw...

Ich kann ihn jedoch nicht stoppen, nicht starten usw...

das ist bei beiden Servern.

Ich habe schon alles mehrmals nachgeschaut.

wenn ich

su www-date
sudo -u "user" /path zum serverstarten eingebe..

kommt genau das gleiche...
er schreibt, dass er startet, aber mehr auch nichts.

in der error.log steht auch nichts drin

Ich hoffe ihr könnt mir helfen, weil das Interface einfach extrem gut gearbeitet hat, und ich es gerne wieder so haben möchte.
Beitrag vom 12.09.2009 - 22:36
Diesen Beitrag melden   zum Anfang der Seite
Zyrusthc ist offline Zyrusthc  
Administrator
712 Beiträge - Alter Hase
Zyrusthc`s alternatives Ego
Was steht den in der Syslog nach dem sudo Befehl?
Da sollte das Augenmerk als erstes drauf gehen!




Greeez Oli
Beitrag vom 13.09.2009 - 05:33
Diesen Beitrag melden   nach weiteren Posts von Zyrusthc suchen Zyrusthc`s Profil ansehen Zyrusthc eine E-Mail senden Zyrusthc eine private Nachricht senden Zyrusthc`s Homepage besuchen Zyrusthc zu Ihren Freunden hinzufügen zum Anfang der Seite
Gast thanatos74  
Gast
So genau kann ich es auch nicht sagen.. aber es könnte das sein:
Zitat
modprobe: WARNING: Not loading blacklisted module ipv6
modprobe: WARNING: Not loading blacklisted module ipv6
/USR/SBIN/CRON[10977]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -r -0 rm)
modprobe: WARNING: Not loading blacklisted module ipv6
last message repeated 2 times



also sudoers stimmen auch, wenn ich die auth.log anschaue, log er sich auch normal ein..
Zitat
sudo: www-data : TTY=pts/2 ; PWD=/var/www ; USER="meinuser" ; COMMAND=/var/www/gameinterface/games/cod/start restart




Dieser Beitrag wurde 1 mal editiert, zuletzt von thanatos74 am 13.09.2009 - 12:48.
Beitrag vom 13.09.2009 - 12:44
Diesen Beitrag melden   zum Anfang der Seite
Gast thanatos74  
Gast
keiner ne Idee?
Beitrag vom 14.09.2009 - 21:34
Diesen Beitrag melden   zum Anfang der Seite
Gast thanatos74  
Gast
PUSH!
Beitrag vom 18.09.2009 - 21:24
Diesen Beitrag melden   zum Anfang der Seite
Gast thanatos74  
Gast
Problem besteht immer noch..

jetzt hab ich es mit einem ET server probiert...

wenn ich ihn manuell starte wird er in der index angezeigt.. ich kann auch config editieren...
aber ich kann ich nicht starten, stoppen oder restarten...


Beitrag vom 11.12.2009 - 22:13
Diesen Beitrag melden   zum Anfang der Seite
k1ue2che ist offline k1ue2che  
SUDO!!!!
8 Beiträge - Einmalposter
k1ue2che`s alternatives Ego
geh mal bitte in pfad zum webinterface/games/cod2/ oder cod oder cod4

überall ähnlich

...

öffne die restart.php

Zitat
<?php
$output = shell_exec("sudo -u $cod2user $cod2restart");
echo "Meldungen vom Startscript";
?>


und ersteze sudo -u mit:

sudo -H -u

hoffe das funktioniert

gruß






Dieser Beitrag wurde 1 mal editiert, zuletzt von k1ue2che am 18.03.2010 - 15:33.
Beitrag vom 18.03.2010 - 15:31
Diesen Beitrag melden   nach weiteren Posts von k1ue2che suchen k1ue2che`s Profil ansehen k1ue2che eine E-Mail senden k1ue2che eine private Nachricht senden k1ue2che`s Homepage besuchen k1ue2che zu Ihren Freunden hinzufügen k1ue2che auf ICQ.com zum Anfang der Seite
Gast thanatos74  
Gast
Thx für die antwort, aber...
Hat sich eh erledigt, bin auf ein andere Webinterface umgestiegen.

Das ist der Hammer (GameCreate.com)->
* kostenlos
* unterstützt sogut wie alle Games
* klasse Support
* für jeden Anfäger
* ...und man braucht noch nicht mal apache aufm root am laufen zu haben.

http://gamecreate.com/downloads.php

mfg
Beitrag vom 18.03.2010 - 15:39
Diesen Beitrag melden   zum Anfang der Seite
k1ue2che ist offline k1ue2che  
:D
8 Beiträge - Einmalposter
k1ue2che`s alternatives Ego
Das müssen wir wohl akzeptieren

am wi wurde ja auch ne weile lang schon nix getanen...

Betonung liegt auf wurde, aktuell arbeite ich mit zisu wieder dran und es wird sich einiges verändern.

jedoch wird es nicht so komplex werden wie gamecreate da es ja auch auf etwas schmaleren roots laufen soll und nicht das wi alleine die Hälfte der Ressourcen fressen soll ^^

bis dahin
hf gl gg




Beitrag vom 18.03.2010 - 16:55
Diesen Beitrag melden   nach weiteren Posts von k1ue2che suchen k1ue2che`s Profil ansehen k1ue2che eine E-Mail senden k1ue2che eine private Nachricht senden k1ue2che`s Homepage besuchen k1ue2che zu Ihren Freunden hinzufügen k1ue2che auf ICQ.com zum Anfang der Seite
Gast thanatos74  
Gast
Damit es meine Member einfacher haben, bin ich wieder auf das "alte" umgestiegen.

Und ich hatte das gleiche Problem, aber mit der Hilfe:

ersteze sudo -u mit:
sudo -H -u

hat es geklappt

Thx
Beitrag vom 08.02.2011 - 15:08
Diesen Beitrag melden   zum Anfang der Seite
Baumstruktur - Signaturen verstecken
Seiten (1): (1) vorheriges Thema   nächstes Thema

Gehe zu:  
Es ist / sind gerade 0 registrierte(r) Benutzer und 33 Gäste online. Neuester Benutzer: Scarez
Mit 3855 Besuchern waren am 02.09.2011 - 14:07 die meisten Besucher gleichzeitig online.
Alles gute zum Geburtstag    Wir gratulieren ganz herzlich zum Geburtstag:
DrRAiNDROP (42)
Aktive Themen der letzten 24 Stunden | Foren-Topuser
 
Seite in 0.21193 Sekunden generiert


Diese Website wurde mit PHPKIT WCMS erstellt
PHPKIT ist eine eingetragene Marke der mxbyte GbR © 2002-2009